On Wed, Mar 21, 2018 at 09:32:18PM +0100, Thomas Monjalon wrote: > Hi, > > 21/03/2018 14:21, Xiao Wang: > > +#endif /* VFIO_PRESENT */ > > #endif /* _RTE_VFIO_H_ */ > > Please keep the empty line which was present between endif. > > > + rte_vfio_create_container; > > + rte_vfio_destroy_container; > > + rte_vfio_bind_group_no; > > + rte_vfio_unbind_group_no; > > + rte_vfio_dma_map; > > + rte_vfio_dma_unmap; > > + rte_vfio_get_group_fd; > > Please keep alphabetical order. > > About the naming, I see "no" and "idx" are used. > Other APIs in DPDK are using "num" and "id". Any strong opinion?
{bind,unbind}_group is sufficient as a name. _no is redundant as implicit from the parameter type. -- Gaëtan Rivet 6WIND