On Mon, Jan 29, 2018 at 12:55:35PM +0100, Thomas Monjalon wrote: > 29/01/2018 12:10, Van Haaren, Harry: > > > From: Thomas Monjalon [mailto:tho...@monjalon.net] > > > Sent: Monday, January 29, 2018 10:56 AM > > > To: Van Haaren, Harry <harry.van.haa...@intel.com> > > > Cc: dev@dpdk.org; Varghese, Vipin <vipin.vargh...@intel.com> > > > Subject: Re: [PATCH v2 2/4] eal: add function to release internal > > > resources > > > > > > 29/01/2018 11:45, Harry van Haaren: > > > > --- a/doc/guides/prog_guide/env_abstraction_layer.rst > > > > +++ b/doc/guides/prog_guide/env_abstraction_layer.rst > > > > +Finalizing and Cleanup > > > > +~~~~~~~~~~~~~~~~~~~~~~ > > > > + > > > > +During the initialization of EAL resources such as hugepage backed > > > > memory > > > can be > > > > +allocated by core components. The memory allocated during > > > ``rte_eal_init()`` > > > > +can be released by calling the ``rte_eal_finalize()`` function. Refer > > > > to > > > the > > > > +API documentation for details. > > > > > > About naming, what is better between > > > rte_eal_finalize() and > > > rte_eal_cleanup() ? > > > I tend to think that "cleanup" is more descriptive. > > > > Sure cleanup() is fine for me, I'll spin a v3 with the function name change. > > Harry, it is a real question! > If someone thinks "finalize" is better, I would like to hear it > because we may use the same wording in more DPDK functions. >
I like finalize better. 1) Both initialize and finalize sound similar as both end in "ize" so sound like they are a pair 2) The use of .init and .fini elf sessions are precedent for the naming /Bruce