On 1/15/2018 6:01 PM, Jerin Jacob wrote:
Introduce a new helper for pktmbuf pool, which will allow
the application to optionally specify the mempool ops name
as well.
Signed-off-by: Hemant Agrawal <hemant.agra...@nxp.com>
---
lib/librte_mbuf/rte_mbuf.c | 23 ++++++++++++++------
lib/librte_mbuf/rte_mbuf.h | 42 ++++++++++++++++++++++++++++++++++++
lib/librte_mbuf/rte_mbuf_version.map | 1 +
3 files changed, 60 insertions(+), 6 deletions(-)
<snip>...
+rte_pktmbuf_pool_create_specific(const char *name, unsigned int n,
No strong opinion on name. I think, rte_pktmbuf_pool_create_by_op() may be
a better name than rte_pktmbuf_pool_create_specific()
yes. looks better. I will change it in next rev.