On 1/12/2018 10:06 PM, Thomas Monjalon wrote:
07/12/2017 11:28, Hemant Agrawal:
other vfio based module e.g. fslmc will also need to use
the clear_group call.
So, exposing it and renaming it to *rte_vfio_clear_group*
Signed-off-by: Hemant Agrawal <hemant.agra...@nxp.com>
---
--- a/lib/librte_eal/linuxapp/eal/eal_vfio.h
+++ b/lib/librte_eal/linuxapp/eal/eal_vfio.h
@@ -179,7 +179,7 @@ vfio_get_group_fd(int iommu_group_no);
/* remove group fd from internal VFIO group fd array */
int
-clear_group(int vfio_group_fd);
+rte_vfio_clear_group(int vfio_group_fd);
The function should be moved to lib/librte_eal/common/include/rte_vfio.h
and an empty implementation must be added for BSD.
I am sending v2 for that.
Related note: in drivers/bus/fslmc/fslmc_vfio.h there is
#include "eal_vfio.h"
Can it be removed?
Yes but it will be different change.
Currently fslmc_vfio.h is is using few "vfio_get_xxx" functions. I will
plan that cleanup in different patch.