> From: dev [mailto:dev-boun...@dpdk.org] On Behalf Of Bruce Richardson > Sent: Friday, September 1, 2017 11:04 AM > To: dev@dpdk.org > Cc: Richardson, Bruce <bruce.richard...@intel.com> > Subject: [dpdk-dev] [PATCH 01/17] build: add initial infrastructure for meson > & > ninja builds
<snip commit message etc> > diff --git a/config/meson.build b/config/meson.build <snip> > +# set the machine type and cflags for it > +machine = get_option('machine') > +dpdk_conf.set('RTE_MACHINE', machine) > +add_project_arguments('-march=@0@'.format(machine), language: 'c') > +# some libs depend on maths lib > +add_project_link_arguments('-lm', language: 'c') > + > +# add -include rte_config to cflags > +add_project_arguments('-include', 'rte_config.h', language: 'c') > + > +# disable any unwanted warnings > +unwanted_warnings = [ > + '-Wno-address-of-packed-member', > + '-Wno-format-truncation' > +] Feedback from usage while developing new features; - Mis-matched integer sign comparison doesn't cause a warning - And -Werror isn't set by default Adding these as per below fixes things... but for cleanliness "unwanted warnings" should probably be renamed, we want more warnings! :D # disable any unwanted warnings unwanted_warnings = [ '-Werror', '-Wno-address-of-packed-member', '-Wno-format-truncation', '-Wsign-compare', ] The performance of Ninja is amazing for testing shared-object builds and version.map changes - feedback is instant. Makes light work of re-checking ABI/API stuff. > +foreach arg: unwanted_warnings > + if cc.has_argument(arg) > + add_project_arguments(arg, language: 'c') > + endif > +endforeach > +