On Mon, Sep 04, 2017 at 11:24:07AM +0100, Bruce Richardson wrote:
> On Mon, Sep 04, 2017 at 10:38:08AM +0100, Van Haaren, Harry wrote:
> > > From: dev [mailto:dev-boun...@dpdk.org] On Behalf Of Sergio Gonzalez
> > > Monroy
> > > Sent: Wednesday, August 23, 2017 4:00 PM
> > > To: dev@dpdk.org
> > > Cc: Ananyev, Konstantin <konstantin.anan...@intel.com>; Richardson, Bruce
> > > <bruce.richard...@intel.com>
> > > Subject: [dpdk-dev] [PATCH] eal/x86: implement x86 specific tsc hz
> > >
<snip>
> > +
> > > +static uint32_t
> > > +check_model_wsm_nhm(uint8_t model)
> > > +{
> > > + switch (model) {
> > > + /* Westmere */
> > > + case 0x25:
> > > + case 0x2C:
> > > + case 0x2F:
> > > + /* Nehalem */
> > > + case 0x1E:
> > > + case 0x1F:
> > > + case 0x1A:
> > > + case 0x2E:
> > > + return 1;
> > > + }
> >
> > DPDK coding standards say /* fallthrough */ comments required when falling
> > through cases.
> > In this case I feel it would reduce readability, more than it improves it,
> > but I recall
> > some recent gcc/clang prints warnings if no /* fallthrough */ comments
> > exist.. opinions?
> >
> > Same for switch() below.
> >
>
> I see no warnings in this case with gcc 7.x. I don't think it counts as
> a fallthrough unless there is code after the label - i.e. multiple
> labels though technically fallthrough are treated as such by compiler.
>
apologies, typo: ... are NOT treated as such ...