On Fri, Jun 30, 2017 at 11:11:42AM +0200, Gaëtan Rivet wrote: > On Fri, Jun 30, 2017 at 11:06:03AM +0200, Thomas Monjalon wrote: > > 29/06/2017 20:22, Jan Blunck: > > > /** > > > + * Hotplug add a given device to a specific bus. > > > + * > > > + * @param busname > > > + * The bus name the device is added to. > > > + * @param devname > > > + * The device name. Based on this device name, eal will identify a > > > driver > > > + * capable of handling it and pass it to the driver probing function. > > > + * @param devargs > > > + * Device arguments to be passed to the driver. > > > + * @return > > > + * 0 on success, negative on error. > > > + */ > > > +int rte_eal_hotplug_add(const char *busname, const char *devname, > > > + const char *devargs); > > > > After the hotplug, we may need to get the rte_device. > > Should we add a struct **rte_device as parameter, > > or should we add a helper function to get the rte_device > > from busname and devname? > > Also possible: return a struct *rte_device and set rte_errno on error. > +1 for this option.
- [dpdk-dev] [PATCH v7 04/15] pci: implement find_device bu... Jan Blunck
- [dpdk-dev] [PATCH v7 09/15] bus: add rte_bus_find_by_name Jan Blunck
- [dpdk-dev] [PATCH v7 10/15] bus: introduce device plug/un... Jan Blunck
- [dpdk-dev] [PATCH v7 11/15] vdev: implement unplug bus op... Jan Blunck
- [dpdk-dev] [PATCH v7 12/15] pci: implement hotplug bus op... Jan Blunck
- [dpdk-dev] [PATCH v7 07/15] bus: add bus iterator to find... Jan Blunck
- Re: [dpdk-dev] [PATCH v7 07/15] bus: add bus iterato... Thomas Monjalon
- [dpdk-dev] [PATCH v7 13/15] eal: add hotplug add/remove f... Jan Blunck
- Re: [dpdk-dev] [PATCH v7 13/15] eal: add hotplug add... Thomas Monjalon
- Re: [dpdk-dev] [PATCH v7 13/15] eal: add hotplug... Gaëtan Rivet
- Re: [dpdk-dev] [PATCH v7 13/15] eal: add hot... Bruce Richardson
- Re: [dpdk-dev] [PATCH v7 13/15] eal: add... Jan Blunck
- Re: [dpdk-dev] [PATCH v7 13/15] eal: add... Thomas Monjalon
- Re: [dpdk-dev] [PATCH v7 13/15] eal: add... Gaëtan Rivet
- Re: [dpdk-dev] [PATCH v7 13/15] eal: add... Bruce Richardson
- Re: [dpdk-dev] [PATCH v7 13/15] eal: add... Thomas Monjalon
- Re: [dpdk-dev] [PATCH v7 13/15] eal: add hotplug add... Thomas Monjalon
- [dpdk-dev] [PATCH v7 14/15] dev: use new hotplug API in a... Jan Blunck
- Re: [dpdk-dev] [PATCH v7 14/15] dev: use new hotplug... Thomas Monjalon
- [dpdk-dev] [PATCH v7 15/15] ethdev: Use embedded rte_devi... Jan Blunck