2017-03-15 06:19, David Hunt: > +/** > + * Number of packets to deal with in bursts. Needs to be 8 so as to > + * fit in one cache line. > + */ > +#define RTE_DIST_BURST_SIZE (sizeof(rte_xmm_t) / sizeof(uint16_t))
error: 'rte_xmm_t' undeclared here (arm compilation) Can it be fixed by including rte_vect.h? Ideally I would prefer we stop using XMM types in a generic code. XMM are x86-only registers. It has been translated for other arches but we should use a more generic name. What was the intention here? SSE-optimized code or 128-bit size? Please check lib/librte_eal/common/include/generic/rte_vect.h for a generic type.