On Thu, 23 Feb 2017 17:23:55 +0000, Bruce Richardson <bruce.richard...@intel.com> wrote: > create a common structure to hold the metadata for the producer and > the consumer, since both need essentially the same information - the > head and tail values, the ring size and mask. > > Signed-off-by: Bruce Richardson <bruce.richard...@intel.com> > --- > lib/librte_ring/rte_ring.h | 32 ++++++++++++++++---------------- > 1 file changed, 16 insertions(+), 16 deletions(-) > > diff --git a/lib/librte_ring/rte_ring.h b/lib/librte_ring/rte_ring.h > index 04fe667..0c8defd 100644 > --- a/lib/librte_ring/rte_ring.h > +++ b/lib/librte_ring/rte_ring.h > @@ -1,7 +1,7 @@ > /*- > * BSD LICENSE > * > - * Copyright(c) 2010-2014 Intel Corporation. All rights reserved. > + * Copyright(c) 2010-2017 Intel Corporation. All rights reserved. > * All rights reserved. > * > * Redistribution and use in source and binary forms, with or > without @@ -139,6 +139,19 @@ struct rte_ring_debug_stats { > > struct rte_memzone; /* forward declaration, so as not to require > memzone.h */ > +/* structure to hold a pair of head/tail values and other metadata */ > +struct rte_ring_ht_ptr {
Just wondering if we can find a better name for this structure. I'm not sure '_ptr' is really relevant. What do you think of: rte_ring_endpoint rte_ring_ht rte_ring_headtail Olivier