On 11/01/2017 06:41, Qiming Yang wrote:
This patch adds a new function eth_igb_fw_version_get.
Signed-off-by: Qiming Yang <qiming.y...@intel.com>
[..]
+static int
+eth_igb_fw_version_get(struct rte_eth_dev *dev, char *fw_version,
+ size_t fw_size)
+{
+ struct e1000_hw *hw = E1000_DEV_PRIVATE_TO_HW(dev->data->dev_private);
+ struct e1000_fw_version fw;
+
+ if (fw_size < 16) {
Magic number. Ought to be #define value (or at least a comment
explaining the choice of size)..
Otherwise looking good.. :)
..Remy