Hi, On 05/31/2016 03:47 PM, Hunt, David wrote: > On 5/31/2016 1:06 PM, Jan Viktorin wrote: >> On Tue, 31 May 2016 10:09:42 +0100 >> "Hunt, David" <david.hunt at intel.com> wrote: >> >>> The *p pointer is the opaque data for a given mempool handler (ring, >>> array, linked list, etc) >> Again, doc comments... >> >> I don't like the obj_table representation to be an array of void *. I >> could see >> it already in DPDK for defining Ethernet driver queues, so, it's >> probably not >> an issue. I just say, I would prefer some basic type safety like >> >> struct rte_mempool_obj { >> void *p; >> }; >> >> Is there somebody with different opinions? >> >> [...] > > Comments added. I've left as a void* for the moment.
Jan, could you please detail why you think having a rte_mempool_obj structure brings more safety? For now, I'm in favor of keeping the array of void *, because that's what we use in other mempool or ring functions. >>>>> +/** Structure defining a mempool handler. */ >>>> Later in the text, I suggested to rename rte_mempool_handler to >>>> rte_mempool_ops. >>>> I believe that it explains the purpose of this struct better. It >>>> would improve >>>> consistency in function names (the *_ext_* mark is very strange and >>>> inconsistent). >>> I agree. I've gone through all the code and renamed to >>> rte_mempool_handler_ops. >> Ok. I meant rte_mempool_ops because I find the word "handler" to be >> redundant. > > I prefer the use of the word handler, unless others also have opinions > either way? Well, I think rte_mempool_ops is clear enough, and shorter, so I'd vote for it. Regards, Olivier