On 5/31/2016 9:40 PM, Olivier MATZ wrote:
[...] >>>>>> +/** Structure defining a mempool handler. */ >>>>> Later in the text, I suggested to rename rte_mempool_handler to >>>>> rte_mempool_ops. >>>>> I believe that it explains the purpose of this struct better. It >>>>> would improve >>>>> consistency in function names (the *_ext_* mark is very strange and >>>>> inconsistent). >>>> I agree. I've gone through all the code and renamed to >>>> rte_mempool_handler_ops. >>> Ok. I meant rte_mempool_ops because I find the word "handler" to be >>> redundant. >> I prefer the use of the word handler, unless others also have opinions >> either way? > Well, I think rte_mempool_ops is clear enough, and shorter, > so I'd vote for it. > OK, I've just changed it. It will be in next revision. :) Regards, Dave.