2016-06-15 10:17, Remy Horton: > +enum rte_keepalive_state { > + RTE_UNUSED = 0, > + RTE_ALIVE = 1, > + RTE_MISSING = 4, > + RTE_DEAD = 2, > + RTE_GONE = 3, > + RTE_DOZING = 5, > + RTE_SLEEP = 6 > +};
I'm concerned about the namespace here. RTE_UNUSED and others have a chance to not be unique enough. Is it possible to have a longer prefix like RTE_KA_ or RTE_STATE_ or RTE_KA_STATE_?