On Fri, Jan 29, 2016 at 12:37 PM, Yuanhan Liu <yuanhan.liu at linux.intel.com> wrote: > On Tue, Jan 19, 2016 at 05:16:07PM +0530, Santosh Shukla wrote: >> For vfio case - Use pread/pwrite api to access virtio >> ioport space. >> >> Applicable for virtio 0.95 spec. >> >> Signed-off-by: Santosh Shukla <sshukla at mvista.com> >> Signed-off-by: Rizwan Ansari <ransari at mvista.com> >> Signed-off-by: Rakesh Krishnamurthy <rakeshk at mvista.com> >> --- >> v4 --> v5: >> - Removed unnecessary type casting. >> >> drivers/net/virtio/virtio_vfio_rw.h | 104 >> +++++++++++++++++++++++++++++++++++ >> 1 file changed, 104 insertions(+) >> create mode 100644 drivers/net/virtio/virtio_vfio_rw.h >> >> diff --git a/drivers/net/virtio/virtio_vfio_rw.h >> b/drivers/net/virtio/virtio_vfio_rw.h >> new file mode 100644 >> index 0000000..a9ab04d >> --- /dev/null >> +++ b/drivers/net/virtio/virtio_vfio_rw.h > > Maybe virtio_vfio.h is enough, or if you have to put a sufix there, _io > (instead of _rw) is a better option to me. >
Ok. >> + >> +/* vfio rd/rw virtio apis */ >> +static inline void >> +ioport_inb(const struct rte_pci_device *pci_dev, uint8_t reg, uint8_t *val) > > vfio_inb is a better name; ioport_inb is too generic. > Ok. > --yliu