On Fri, Jan 08, 2016 at 12:23:15AM +0530, Santosh Shukla wrote: > > > On Thu, Jan 7, 2016 at 11:46 PM, Stephen Hemminger <stephen at > networkplumber.org> > wrote: > ? > > > +? ? ? ? ? ? ?ret = pread64(vfio_dev_fd, &ioport_bar, > sizeof(ioport_bar), > > +? ? ? ? ? ? ? ? ? ? ? ? ? ?VFIO_GET_REGION_ADDR > (VFIO_PCI_CONFIG_REGION_INDEX) > > +? ? ? ? ? ? ? ? ? ? ? ? ? ?+ PCI_BASE_ADDRESS_0 + i*4); > > + > > +? ? ? ? ? ? ?if (ret != sizeof(ioport_bar)) { > > +? ? ? ? ? ? ? ? ? ? ?RTE_LOG(ERR, EAL, > > +? ? ? ? ? ? ? ? ? ? ? ? ? ? ?"Cannot read command (%x) from PCI config" > > +? ? ? ? ? ? ? ? ? ? ? ? ? ? ?"space!\n", PCI_BASE_ADDRESS_0 + i*4); > > Please dont split the line of a log message string in mid sentence. >
First of all, it'd be good if you can fix your email client to reply emails in a way open source world prefer, such as prefixing last email with leading '> ', and do not auto fold lines. > me to don't like splitting, This was deliberate to keep checkpatch happy, If > we > are ok with debug message > 80 line warning I guess ?it will improve code > readability. You may try to shorten your message to "Cannot read cmd %x from config space!" :) > > > > +? ? ? ? ? ? ? ? ? ? ?return -1; > > +? ? ? ? ? ? ?} > > + > > +? ? ? ? ? ? ?if (ioport_bar & PCI_BASE_ADDRESS_SPACE_IO) { > > +? ? ? ? ? ? ? ? ? ? ?RTE_LOG(INFO, EAL, "\tIgnore mapping since Its a > i/ > o" > > +? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? "port bar (%d) addr : %x\n", i, > same here > > > Agreed. Ditto, maybe following is better "Ignore mapping IO port bar %d, addr: %x\n". --yliu