> BPF opcode macro names had small deviations from the ones defined in > Linux headers, confusing humans and AI tools during code generation and > analysis, since both are mostly trained on the Linux spelling. > > Rename them to match Linux counterparts. But then, there would be a risk that inside DPDK code we will use definitions provided by linux includes without even noticing that? I understand that both should boil down to the same values, but still sort of grey area here... Shall we add 'RTE_' or '_RTE_' prefix to our own ones? > > Signed-off-by: Marat Khalili <[email protected]> > ---
- [PATCH v2 0/2] bpf_def.h cleanups Marat Khalili
- [PATCH v2 1/2] bpf: make bpf_def.h private Marat Khalili
- RE: [PATCH v2 1/2] bpf: make bpf_def.h private Konstantin Ananyev
- RE: [PATCH v2 2/2] bpf: rename macros to match Lin... Konstantin Ananyev
- [PATCH v3 0/1] bpf_def.h cleanups Marat Khalili
- [PATCH v3 1/1] bpf: make bpf_def.h private Marat Khalili
- Re: [PATCH v3 1/1] bpf: make bpf_def.h pri... Marat Khalili
- [PATCH v4 0/1] bpf_def.h cleanups Marat Khalili
- [PATCH v4 1/1] bpf: make bpf_def.h private Marat Khalili
- Re: [PATCH v4 1/1] bpf: make bpf_def.h... Marat Khalili
- Re: [PATCH v4 1/1] bpf: make bpf_def.h... Marat Khalili
- Re: [PATCH v4 1/1] bpf: make bpf_def.h... Marat Khalili

