> Both `bpf_def.h` header file and the symbols it defined were not > previously prefixed with `rte_`, creating an opportunity for name > conflicts. Status of the file itself (private or public) was unclear. > > Move public symbols after adding the necessary prefix (`rte_ebpf_insn` > and `RTE_BPF_FUNC_MAX_ARGS`) into the public header file `rte_bpf.h`, > and make the rest private. > > Signed-off-by: Marat Khalili <[email protected]> > --- Acked-by: Konstantin Ananyev <[email protected]> As it is a public API change - It is probably worth a line or two in official RN for 26.11 > -- > 2.43.0
- [PATCH v2 0/2] bpf_def.h cleanups Marat Khalili
- [PATCH v2 1/2] bpf: make bpf_def.h private Marat Khalili
- RE: [PATCH v2 1/2] bpf: make bpf_def.h private Konstantin Ananyev
- RE: [PATCH v2 2/2] bpf: rename macros to match Lin... Konstantin Ananyev
- [PATCH v3 0/1] bpf_def.h cleanups Marat Khalili
- [PATCH v3 1/1] bpf: make bpf_def.h private Marat Khalili
- Re: [PATCH v3 1/1] bpf: make bpf_def.h pri... Marat Khalili
- [PATCH v4 0/1] bpf_def.h cleanups Marat Khalili
- [PATCH v4 1/1] bpf: make bpf_def.h private Marat Khalili
- Re: [PATCH v4 1/1] bpf: make bpf_def.h... Marat Khalili
- Re: [PATCH v4 1/1] bpf: make bpf_def.h... Marat Khalili
- Re: [PATCH v4 1/1] bpf: make bpf_def.h... Marat Khalili

