On Wed, 2 Apr 2025 06:58:56 +0000 liwencheng <liwench...@phytium.com.cn> wrote:
> add Phytium NIC MACB ethdev PMD driver. > > v4: > * Changed functions that always return 0 and whose return value > is unused to void type, improving code simplicity and readability. > * Fixed the implicit conversion issues in the > macb_usxgmii_pcs_check_for_link and > macb_usxgmii_pcs_check_for_link functions. > * Added the missing SPDX license tags. > * Fix tab errors in meson.build file. > * Use RTE_LOG_LINE instead of rte_log. > * Replace %l with %PRI*64. > * Replace rte_smp_[r/w]mb with rte_[r/w]mb. > * Do not use variadic arguments in macros. > * Do not use variable-length array pkts[nb_bufs]. > * Use __rte_cache_aligned only for struct or union types alignment. > * Support hardware Rx/Tx checksum offload. > * Fixed some code style issues. > > Signed-off-by: liwencheng <liwench...@phytium.com.cn> These checkpatch warnings can be avoided by putting __rte_unused after the declaration. I.e eth_macb_xmit_pkts_vec(void *tx_queue __rte_unused, CHECK:SPACING: spaces preferred around that '*' (ctx:WxV) #7246: FILE: drivers/net/macb/macb_rxtx.c:1370: +eth_macb_recv_pkts_vec(void __rte_unused *rx_queue, ^ CHECK:SPACING: spaces preferred around that '*' (ctx:WxO) #7247: FILE: drivers/net/macb/macb_rxtx.c:1371: + struct rte_mbuf __rte_unused **rx_pkts, ^ CHECK:SPACING: spaces preferred around that '*' (ctx:WxV) #7254: FILE: drivers/net/macb/macb_rxtx.c:1378: +eth_macb_recv_scattered_pkts_vec(void __rte_unused *rx_queue, ^ CHECK:SPACING: spaces preferred around that '*' (ctx:WxO) #7255: FILE: drivers/net/macb/macb_rxtx.c:1379: + struct rte_mbuf __rte_unused **rx_pkts, ^ CHECK:SPACING: spaces preferred around that '*' (ctx:WxV) #7262: FILE: drivers/net/macb/macb_rxtx.c:1386: +eth_macb_xmit_pkts_vec(void __rte_unused *tx_queue, ^ CHECK:SPACING: spaces preferred around that '*' (ctx:WxO) #7263: FILE: drivers/net/macb/macb_rxtx.c:1387: + struct rte_mbuf __rte_unused **tx_pkts, ^