On 2024-12-12 08:57, David Marchand wrote:
On Fri, Dec 6, 2024 at 12:29 PM Mattias Rönnblom <hof...@lysator.liu.se> wrote:
I would wrap all RTE_LCORE_VAR_LCORE() and RTE_LCORE_VAR().
static struct pmd_core_cfg *
get_cfg_lcore(unsigned int lcore_id)
{
assure_lcore_cfgs_alloced();
return RTE_LCORE_VAR_LCORE(lcore_cfgs, lcore_id);
}
static struct pmd_core_cfg *
get_cfg(void)
{
get_cfg_lcore(rte_lcore_id());
}
Add
static void
assure_lcore_cfgs_alloced(unsigned int lcore_id)
{
if (lcore_cfgs != NULL)
==
Oops.
lcore_cfgs_alloc();
}
..or maybe better merge assure_lcore_cfgs_alloced() and lcore_cfgs_alloc().
Makes it a little harder to make mistakes.
clb_multiwait, clb_pause and clb_scale_freq callbacks can only be
reached after a successful call to
rte_power_ethdev_pmgmt_queue_enable.
Triggering an allocation in them means we are hiding a (internal)
programatic error as allocation and use of a lcore variable are
clearly separated atm.
If we keep the lcore var api as is, I would add an assert() (maybe
under a debug build option) in RTE_LCORE_VAR macros themselves, as
calling with a NULL handle means the initialisation path in some
code/RTE_LCORE_VAR API use was incorrect.
Sure, that would make sense. RTE_ASSERT(), that is. RTE_VERIFY() would
be too expensive.
Or because you propose to add the same type of helpers in both this
patch and the next, I am considering the other way: hide the
allocation in the RTE_LCORE_VAR* macros.
Checking for already allocated var in RTE_LCORE_VAR_ALLOC seems fine.
But the "fast path" RTE_LCORE_VAR would have an unwanted branch in most cases.
I would prefer to have the ALLOC() macro with semantics most people
expect from a macro (or function) with that name, which is, I would
argue, an unconditional allocation.
It would make sense to have another macro, which performs an allocation
only if the handle is NULL.
RTE_LCORE_VAR_ASSURE_ALLOCATED(), or just RTE_LCORE_VAR_ASSURE()
(although the latter sounds a little like an assertion, and not an
allocation).
RTE_LCORE_VAR_LAZY_ALLOC()
I don't know. Something like that.
A somewhat unrelated question: why is pmd_core_cfg cache-line aligned? I
don't think it should be.
Before the conversion to per lcore variable, it was probably useful
(avoiding false sharing).
With the conversion, indeed, it looks like a waste of space.
It seems worth a separate fix.
You will include it, or should I submit a separate patch?