> From: Aditya Ambadipudi [mailto:aditya.ambadip...@arm.com] > Sent: Monday, 1 April 2024 03.37 > > From: Honnappa Nagarahalli <honnappa.nagaraha...@arm.com> > > Add a multi-thread unsafe double ended queue data structure. This > library provides a simple and efficient alternative to multi-thread > safe ring when multi-thread safety is not required. > > Signed-off-by: Aditya Ambadipudi <aditya.ambadip...@arm.com> > Signed-off-by: Honnappa Nagarahalli <honnappa.nagaraha...@arm.com> > ---
This is a good contribution, thank you. Two high-level comments: 1. Please use head/tail explicitly in function names, not implicitly. E.g. rename rte_deque_enqueue_bulk_elem() to rte_deque_enqueue_at_head_bulk_elem(), like rte_deque_enqueue_at_tail_bulk_elem(). Also consider removing "at" from the function names, e.g. rte_deque_(head|tail)_enqueue_bulk_elem() instead of rte_deque_enqueue_at_(head|tail)_bulk_elem(). 2. In the future, someone might come up with a lock-free implementation, like for the stack. Please ensure that the API and documentation is prepared for that, so we don't have to use a different namespace for such a lock-free implementation. I haven't reviewed the patch thoroughly; if it is already be prepared for this, you can ignore this comment.