Hi, > -----Original Message----- > From: Thomas Monjalon <tho...@monjalon.net> > Sent: Monday, February 5, 2024 8:39 PM > To: Suanming Mou <suanmi...@nvidia.com> > Cc: dev@dpdk.org; ferruh.yi...@amd.com; Ori Kam <or...@nvidia.com>; Aman > Singh <aman.deep.si...@intel.com>; Yuying Zhang <yuying.zh...@intel.com>; > Dariusz Sosnowski <dsosnow...@nvidia.com>; Slava Ovsiienko > <viachesl...@nvidia.com>; Matan Azrad <ma...@nvidia.com>; Andrew > Rybchenko <andrew.rybche...@oktetlabs.ru>; dev@dpdk.org > Subject: Re: [PATCH v6 1/3] ethdev: rename action modify field data structure > > > > > --- a/lib/ethdev/rte_flow.h > > > > +++ b/lib/ethdev/rte_flow.h > > > > @@ -3894,6 +3894,7 @@ struct rte_flow_action_ethdev { > > > > > > > > /** > > > > * Field IDs for MODIFY_FIELD action. > > > > + * e.g. the packet field IDs used in > RTE_FLOW_ACTION_TYPE_MODIFY_FIELD. > > > > > > Better to give the full name in the first line, so no need to add a > > > second line of comment. > > > > So maybe " Field IDs for packet field, used by > RTE_FLOW_ACTION_TYPE_MODIFY_FIELD."? > > Yes, or just > "Packet header field IDs, used by RTE_FLOW_ACTION_TYPE_MODIFY_FIELD." > > > But when COMPARE item to be added. It will be " Field IDs for packet field, > > used > by RTE_FLOW_ACTION_TYPE_MODIFY_FIELD and > RTE_FLOW_ITEM_TYPE_COMPARE." And I assume that will still need a second > line since it is too long. > > Yes no problem, I'm just trying to have something concise while being > explicit and > easy to read.
Got it, thanks. Will update. > >