05/01/2024 10:54, Jerin Jacob: > On Fri, Jan 5, 2024 at 4:04 AM Thomas Monjalon <tho...@monjalon.net> wrote: > > > > 19/12/2023 18:29, jer...@marvell.com: > > > --- a/doc/guides/nics/features/default.ini > > > +++ b/doc/guides/nics/features/default.ini > > > @@ -59,6 +59,7 @@ Packet type parsing = > > > > > > Timesync = > > > Rx descriptor status = > > > Tx descriptor status = > > > +Tx free descriptor query = > > > > I think we can drop "query" here. > > How about "Tx queue free count" then?
No strong opinion. What others think? > > > +__rte_experimental > > > +static inline uint32_t > > > +rte_eth_tx_queue_free_desc_get(uint16_t port_id, uint16_t tx_queue_id) > > > > For consistency with rte_eth_rx_queue_count(), > > I propose the name rte_eth_tx_queue_free_count(). > > Make sense. I will change it in next version.