04/01/2024 15:21, Konstantin Ananyev: > > > > > Introduce a new API to retrieve the number of available free descriptors > > > > in a Tx queue. Applications can leverage this API in the fast path to > > > > inspect the Tx queue occupancy and take appropriate actions based on the > > > > available free descriptors. > > > > > > > > A notable use case could be implementing Random Early Discard (RED) > > > > in software based on Tx queue occupancy. > > > > > > > > Signed-off-by: Jerin Jacob <jer...@marvell.com> > > > > > > I think having an API to get the number of free descriptors per queue is > > > a good idea. Why have it only for TX queues and not for RX > > queues as well? > > > > I see no harm in adding for Rx as well. I think, it is better to have > > separate API for each instead of adding argument as it is fast path > > API. > > If so, we could add a new API when there is any PMD implementation or > > need for this. > > I think for RX we already have similar one: > /** @internal Get number of used descriptors on a receive queue. */ > typedef uint32_t (*eth_rx_queue_count_t)(void *rxq);
rte_eth_rx_queue_count() gives the number of Rx used descriptors rte_eth_rx_descriptor_status() gives the status of one Rx descriptor rte_eth_tx_descriptor_status() gives the status of one Tx descriptor This patch is adding a function to get Tx available descriptors, rte_eth_tx_queue_free_desc_get(). I can see a symmetry with rte_eth_rx_queue_count(). For consistency I would rename it to rte_eth_tx_queue_free_count(). Should we add rte_eth_tx_queue_count() and rte_eth_rx_queue_free_count()?