On Thu, Dec 21, 2023 at 05:41:40PM +0000, Euan Bourke wrote:
> Removed LIBRTE from name as its an old prefix.
> 
> Signed-off-by: Euan Bourke <euan.bou...@intel.com>
> ---
>  app/test/test_reassembly_perf.c                      | 2 +-
>  config/rte_config.h                                  | 2 +-
>  doc/guides/prog_guide/ip_fragment_reassembly_lib.rst | 8 ++++----
>  doc/guides/sample_app_ug/ip_reassembly.rst           | 4 ++--
>  examples/ip_fragmentation/main.c                     | 2 +-
>  examples/ip_reassembly/main.c                        | 2 +-
>  examples/ipsec-secgw/ipsec_worker.h                  | 2 +-
>  lib/ip_frag/ip_reassembly.h                          | 2 +-
>  lib/ip_frag/rte_ip_frag.h                            | 2 +-
>  9 files changed, 13 insertions(+), 13 deletions(-)
> 
> diff --git a/app/test/test_reassembly_perf.c b/app/test/test_reassembly_perf.c
> index 3912179022..805ae2fe9d 100644
> --- a/app/test/test_reassembly_perf.c
> +++ b/app/test/test_reassembly_perf.c
> @@ -20,7 +20,7 @@
>  #define MAX_FLOWS        (1024 * 32)
>  #define MAX_BKTS         MAX_FLOWS
>  #define MAX_ENTRIES_PER_BKT 16
> -#define MAX_FRAGMENTS            RTE_LIBRTE_IP_FRAG_MAX_FRAG
> +#define MAX_FRAGMENTS            RTE_IP_FRAG_MAX_FRAG
>  #define MIN_FRAGMENTS            2
>  #define MAX_PKTS         (MAX_FLOWS * MAX_FRAGMENTS)
>  
> diff --git a/config/rte_config.h b/config/rte_config.h
> index da265d7dd2..e2fa2a58fa 100644
> --- a/config/rte_config.h
> +++ b/config/rte_config.h
> @@ -85,7 +85,7 @@
>  #define RTE_RAWDEV_MAX_DEVS 64
>  
>  /* ip_fragmentation defines */
> -#define RTE_LIBRTE_IP_FRAG_MAX_FRAG 8
> +#define RTE_IP_FRAG_MAX_FRAG 8
>  // RTE_LIBRTE_IP_FRAG_TBL_STAT is not set
>  
>  /* rte_power defines */
> diff --git a/doc/guides/prog_guide/ip_fragment_reassembly_lib.rst 
> b/doc/guides/prog_guide/ip_fragment_reassembly_lib.rst
> index f3ed90d700..2d422309bb 100644
> --- a/doc/guides/prog_guide/ip_fragment_reassembly_lib.rst
> +++ b/doc/guides/prog_guide/ip_fragment_reassembly_lib.rst
> @@ -43,12 +43,12 @@ Note that all update/lookup operations on Fragment Table 
> are not thread safe.
>  So if different execution contexts (threads/processes) will access the same 
> table simultaneously,
>  then some external syncing mechanism have to be provided.
>  
> -Each table entry can hold information about packets of up to 
> ``RTE_LIBRTE_IP_FRAG_MAX_FRAG`` fragments,
> -where ``RTE_LIBRTE_IP_FRAG_MAX_FRAG`` defaults to:
> +Each table entry can hold information about packets of up to 
> ``RTE_IP_FRAG_MAX_FRAG`` fragments,
> +where ``RTE_IP_FRAG_MAX_FRAG`` defaults to:
>  
>  .. literalinclude:: ../../../config/rte_config.h
>      :language: c
> -    :start-at: #define RTE_LIBRTE_IP_FRAG_MAX_FRAG
> +    :start-at: #define RTE_IP_FRAG_MAX_FRAG
>      :lines: 1
>  
>  Code example, that demonstrates creation of a new Fragment table:
> @@ -69,7 +69,7 @@ Also, entries that resides in the table longer then 
> <max_cycles> are considered
>  and could be removed/replaced by the new ones.
>  
>  Note that reassembly demands a lot of mbuf's to be allocated.
> -At any given time up to (2 \* bucket_entries \* RTE_LIBRTE_IP_FRAG_MAX \* 
> <maximum number of mbufs per packet>)
> +At any given time up to (2 \* bucket_entries \* RTE_IP_FRAG_MAX \* <maximum 
> number of mbufs per packet>)

Should be RTE_IP_FRAG_MAX_FRAG. You should check all other replacements to
ensure the correct define name is being used. I see a couple of other
occurances in this patch where the name is wrong.

>  can be stored inside Fragment Table waiting for remaining fragments.
>  
<snip for brevity>

Reply via email to