On Tue, Oct 24, 2023 at 11:04 AM Radu Nicolau <radu.nico...@intel.com> wrote: > On 24-Oct-23 9:44 AM, David Marchand wrote: > > On Tue, Oct 24, 2023 at 10:40 AM Radu Nicolau <radu.nico...@intel.com> > > wrote: > >> > >> On 24-Oct-23 6:42 AM, Zhang, Qi Z wrote: > >>>> -----Original Message----- > >>>> From: Radu Nicolau <radu.nico...@intel.com> > >>>> Sent: Tuesday, October 24, 2023 12:38 AM > >>>> To: Wu, Jingjing <jingjing...@intel.com>; Xing, Beilei > >>>> <beilei.x...@intel.com> > >>>> Cc: dev@dpdk.org; Nicolau, Radu <radu.nico...@intel.com>; > >>>> sta...@dpdk.org; Marchand, David <david.march...@redhat.com> > >>>> Subject: [PATCH] net/iavf: fix Tx offloading flags check > >>>> > >>>> Use IAVF_TX_OFFLOAD_MASK flags instead of > >>>> IAVF_TX_CKSUM_OFFLOAD_MASK. > >>>> > >>>> Fixes: 3c715591ece0 ("net/iavf: fix checksum offloading") > >>>> Cc: sta...@dpdk.org > >>>> Cc: david.march...@redhat.com > >>>> > >>>> Signed-off-by: Radu Nicolau <radu.nico...@intel.com> > >>>> --- > >>>> drivers/net/iavf/iavf_rxtx.c | 2 +- > >>>> 1 file changed, 1 insertion(+), 1 deletion(-) > >>>> > >>>> diff --git a/drivers/net/iavf/iavf_rxtx.c b/drivers/net/iavf/iavf_rxtx.c > >>>> index > >>>> c6ef6af1d8..85f8c141ce 100644 > >>>> --- a/drivers/net/iavf/iavf_rxtx.c > >>>> +++ b/drivers/net/iavf/iavf_rxtx.c > >>>> @@ -2664,7 +2664,7 @@ iavf_build_data_desc_cmd_offset_fields(volatile > >>>> uint64_t *qw1, > >>>> l2tag1 |= m->vlan_tci; > >>>> } > >>>> > >>>> - if ((m->ol_flags & IAVF_TX_CKSUM_OFFLOAD_MASK) == 0) > >>>> + if ((m->ol_flags & IAVF_TX_OFFLOAD_MASK) == 0) > >>> Not sure if this will break previous fix. > >>> Could you please provide some clarification regarding the specific > >>> offload flags that not in IAVF_TX_CKSUM_OFFLOAD_MASK, but you still don't > >>> want to skip? > >> A specific flag is RTE_ETH_TX_OFFLOAD_SECURITY, and because this is not > >> contained in IAVF_TX_OFFLOAD_MASK the previous fix broke the inline > >> crypto feature. > > RTE_ETH_TX_OFFLOAD_SECURITY is a ethdev level flag. > > This is not supposed to be in a mbuf ol_flags, is it? > > No, it's not, you are right. Actually it's RTE_MBUF_F_TX_SEC_OFFLOAD, > and that also means the IAVF_TX_OFFLOAD_MASK definition is not correct. > I will send another patch to fix the definition of IAVF_TX_OFFLOAD_MASK.
Thanks. > > As for this fix, if you prefer a safer approach I can add another check > only for RTE_MBUF_F_TX_SEC_OFFLOAD, but one way or the other we need to > have this fix. There are multiple helpers touching offloads in this code and I don't have a clear view of what the best fix for this driver is. My concern is that IAVF_TX_OFFLOAD_MASK mixes both packet types (RTE_MBUF_F_TX_IPV[46], RTE_MBUF_F_TX_OUTER_IPV6[46]...) and actual offloading requests (RTE_MBUF_F_TX_VLAN, RTE_MBUF_F_TX_IP_CKSUM etc...). In the mbuf API, the presence of "packet types" tx flags is not described as something that requires filling l2_len / l3_len etc... For a similar reason, the presence of RTE_MBUF_F_TX_VLAN tells nothing about l2_len / l3_len. So switching to IAVF_TX_OFFLOAD_MASK seems dangerous. As for your suggestion, it seems safer only checking RTE_MBUF_F_TX_SEC_OFFLOAD, I agree. This code is still really hard to follow, so I'll let Intel maintainers advise on the best fix. -- David Marchand