On Wed, Oct 4, 2023 at 8:43 AM Jerin Jacob <jerinjac...@gmail.com> wrote: > > > diff --git a/drivers/common/cnxk/roc_nix_inl_dev.c > > > b/drivers/common/cnxk/roc_nix_inl_dev.c > > > index 6aa191410b..614d0858e5 100644 > > > --- a/drivers/common/cnxk/roc_nix_inl_dev.c > > > +++ b/drivers/common/cnxk/roc_nix_inl_dev.c > > > @@ -826,7 +826,7 @@ nix_inl_outb_poll_thread_setup(struct nix_inl_dev > > > *inl_dev) > > > soft_exp_consumer_cnt = 0; > > > soft_exp_poll_thread_exit = false; > > > rc = plt_thread_create_control(&inl_dev->soft_exp_poll_thread, > > > - "outb-poll", nix_inl_outb_poll_thread, inl_dev); > > > + "outb-soft-exp-poll", nix_inl_outb_poll_thread, > > > inl_dev); > > > > Such a thread name is too long. > > This is reverting Thomas change. > > > > Is this intentional? > > Yes, as mentioned in git commit log. Are 19 characters OK, right? If
The commitlog was ambiguous. > not, I will reduce it, "outb-poll" too generic. The thread name max length in pthread API is 16 bytes (including the trailing \0). Besides, looking again at this driver, I suspect Thomas missed it because of the plt_ prefix, when doing ce703c47de95 ("eal: force prefix for internal threads"). Converting to the internal API would restrict the name down to 11 bytes (including \0). -- David Marchand