Hello Jerin, On Tue, Oct 3, 2023 at 8:40 PM <jer...@marvell.com> wrote: > > From: Jerin Jacob <jer...@marvell.com> > > The common code is shared between different driver environments, > introduce missing plt_ abstractions of missing rte_ symbols and > use plt symbols to avoid changing roc_* files. > > Also update the thread name for outbound soft expiry thread > in a7ba40b2b1bf7. > > Fixes: 3d4e27fd7ff0 ("use abstracted bit count functions") > Fixes: a7ba40b2b1bf ("drivers: convert to internal control threads") > Fixes: c88d3638c7fc ("common/cnxk: support REE") > Cc: sta...@dpdk.org > > Signed-off-by: Jerin Jacob <jer...@marvell.com>
- Could we add something in checkpatch for this driver? I was aware of this s/rte_/plt_/ peculiarity but still missed it... - If you want this backported in LTS, I suggest splitting the fix against c88d3638c7fc ("common/cnxk: support REE") and the rest than only affects current release. - One comment: > diff --git a/drivers/common/cnxk/roc_nix_inl_dev.c > b/drivers/common/cnxk/roc_nix_inl_dev.c > index 6aa191410b..614d0858e5 100644 > --- a/drivers/common/cnxk/roc_nix_inl_dev.c > +++ b/drivers/common/cnxk/roc_nix_inl_dev.c > @@ -826,7 +826,7 @@ nix_inl_outb_poll_thread_setup(struct nix_inl_dev > *inl_dev) > soft_exp_consumer_cnt = 0; > soft_exp_poll_thread_exit = false; > rc = plt_thread_create_control(&inl_dev->soft_exp_poll_thread, > - "outb-poll", nix_inl_outb_poll_thread, inl_dev); > + "outb-soft-exp-poll", nix_inl_outb_poll_thread, > inl_dev); Such a thread name is too long. This is reverting Thomas change. Is this intentional? -- David Marchand