On Mon, Sep 11, 2023 at 06:13:48PM +0200, Thomas Monjalon wrote: > 08/09/2023 06:22, Tyler Retzlaff: > > On Wed, Sep 06, 2023 at 06:12:27PM +0200, Thomas Monjalon wrote: > > > --- a/lib/eal/common/eal_common_thread.c > > > +++ b/lib/eal/common/eal_common_thread.c > > > @@ -248,7 +248,7 @@ struct rte_thread_ctrl_params { > > > enum __rte_ctrl_thread_status ctrl_thread_status; > > > }; > > > > the code above here > > > > struct rte_thread_ctrl_params i think can now get renamed to > > rte_thread_control_params and i think we can get rid of the union. > > if i look through the code history i only added it to help maintain > > compatibility while we had both ctrl and control thread APIs. > > Yes I can do this cleanup. > Instead of rte_thread_control_params, > I would call it control_thread_params as it is private.
sounds good to me, i didn't intend to express a preference about the name just that it could be cleaned up. >