Hi Ferruh, > -----Original Message----- > From: Ferruh Yigit <ferruh.yi...@amd.com> > Sent: Tuesday, May 23, 2023 1:34 PM > > On 5/23/2023 7:59 AM, Ori Kam wrote: > > Hi > > > >> -----Original Message----- > >> From: Ferruh Yigit <ferruh.yi...@amd.com> > >> Sent: Monday, May 22, 2023 1:28 PM > >> > >> On 5/18/2023 10:48 PM, Alexander Kozyrev wrote: > >>> Introduce the new rte_flow_update() API allowing users > >>> to update the action list in the already existing rule. > >> > >> If the API is only to update actions, does make sense to rename it to > >> explicitly state this, like: > >> `rte_flow_action_update()` > >> > >> Same for async version of the API. > >> > > > > I'm O.K with the suggested name. > > Maybe just change action to actions? > > > > Both OK for me, existing APIs have mixed usage of 'action' vs 'actions', > is there a clear distinction when to use one or other? > The idea is that if we have a single action it is action else actions. For example, 1. Template create - rte_flow_actions_template_create since it has number of actions. 2. create indirect action - rte_flow_async_action_handle_create since is create just one action
> > Best, > > Ori > > > >>> Flow rules can be updated now without the need to destroy > >>> the rule first and create a new one instead. > >>> A single API call ensures that no packets are lost by > >>> guaranteeing atomicity and flow state correctness. > >>> The rte_flow_async_update() is added as well. > >>> The matcher is not updated, only the action list is. > >>> > >>> Signed-off-by: Alexander Kozyrev <akozy...@nvidia.com> > >> > >> <...>