On Fri, 3 Mar 2023 21:56:54 +0800 Martzki <mars14...@gmail.com> wrote:
> The library libpcap has their function 'bpf_validate' either so > there would be a multiple definition issue when linking with > librte_bpf.a and libpcap.a staticly. > > You can reproduce this issue by 'meson build -Dprefer_static=true > -Denable_apps=test-pmd -Denable_drivers=net/af_xdp,net/af_packet'. > Notice you need to have a static version of libpcap to reproduce this. > > In 2019 there was a patch reported the same issue but not applied: > https://inbox.dpdk.org/stable/2601191342ceee43887bde71ab9772580148a95...@irsmsx105.ger.corp.intel.com/T > > Since 'bpf_validate' is an internal function, I think adding an 'rte' > prefix is not a good idea and rename it to 'bpf_do_validate' instead. > > Signed-off-by: Martzki <mars14...@gmail.com> Let's change all the function names here to rte_bpf_XXX.