Thanks or your comments, we will use enums to differentiate queues.

As for 'bufq1'&'bufq2', they are members of struct idpf_rx_queue, defined in 
idpf commen module,
And it involves idpf pmd code, so it's better to improve it in the later fixed 
patch.

> -----Original Message-----
> From: Ferruh Yigit <ferruh.yi...@amd.com>
> Sent: Tuesday, February 28, 2023 5:46 AM
> To: Liu, Mingxia <mingxia....@intel.com>; dev@dpdk.org; Xing, Beilei
> <beilei.x...@intel.com>; Zhang, Yuying <yuying.zh...@intel.com>
> Subject: Re: [PATCH v7 03/21] net/cpfl: add Rx queue setup
> 
> On 2/16/2023 12:29 AM, Mingxia Liu wrote:
> > Add support for rx_queue_setup ops.
> >
> > Signed-off-by: Mingxia Liu <mingxia....@intel.com>
> 
> <...>
> 
> > +
> > +   if (bufq_id == 1) {
> > +           rxq->bufq1 = bufq;
> > +   } else if (bufq_id == 2) {
> > +           rxq->bufq2 = bufq;
> 
> For readability better to use enums to diffrentiate queues, instead of using
> 1 and 2 as paramter to function.
> 
> Also I wonder if queue variable names can be improved too, from 'bufq1'
> & 'bufq2' to something more descriptive.

Reply via email to