Jenkins hash function was developed originally in 1996, and was integrated in first versions of DPDK. The function has been improved in 2006, achieving up to 60% better performance, compared to the original one.
This patchset updates the current jhash in DPDK, including two new functions that generate two hashes from a single key. It also separates the existing hash function performance tests to another file, to make it quicker to run. changes in v3: - Update rte_jhash_1word, rte_jhash_2words and rte_jhash_3words functions changes in v2: - Split single commit in three commits, one that updates the existing functions and another that adds two new functions and use one of those functions as a base to be called by the other ones. - Remove some unnecessary ifdefs in the code. - Add new macros to help on the reutilization of constants - Separate hash function performance tests to another file and improve cycle measurements. - Rename existing function rte_jhash2 to rte_jhash_32b (something more meaninful) and mark rte_jhash2 as deprecated De Lara Guarch, Pablo (1): hash: rename rte_jhash2 to rte_jhash_32b Pablo de Lara (5): test/hash: move hash function perf tests to separate file test/hash: improve accuracy on cycle measurements hash: update jhash function with the latest available hash: add two new functions to jhash library hash: remove duplicated code app/test/Makefile | 1 + app/test/test_func_reentrancy.c | 2 +- app/test/test_hash.c | 4 +- app/test/test_hash_func_perf.c | 145 +++++++++++++++++ app/test/test_hash_perf.c | 71 +-------- lib/librte_hash/rte_jhash.h | 336 +++++++++++++++++++++++++++++---------- 6 files changed, 400 insertions(+), 159 deletions(-) create mode 100644 app/test/test_hash_func_perf.c -- 1.7.4.1