On Wed, 25 May 2022 14:45:37 +0000 Mattias Rönnblom <mattias.ronnb...@ericsson.com> wrote:
> I would call it something else than "float", in particular since it > doesn't return "float" but a "double" type floating point value. > > rte_drand() maybe? Short, but might be confused with rte_rand(), given > the visual similarity. I still I would still prefer that over > rte_rand_double(). The corresponding standard library routine is drand48(). With that convention it would be rte_drand().