On 2022-04-08 16:24, Mattias Rönnblom wrote: <snip>
PATCH v4: * Reverted to Linux kernel style naming on the read side.
In this version I chose to adhere to kernel naming on the read side, but keep the write_lock()/unlock() on the write side.
I think those names communicate better what the functions do, but Stephen's comment about keeping naming and semantics close to the Linux kernel APIs is very much relevant, also for the write functions.
I don't really have an opinion if we keep these names, or if we change to rte_seqlock_write_begin()/end().
You might ask yourself which of the two naming options make most sense in the light that we might extend the proposed seqlock API with an "unlocked" (non-writer-serializing) seqlock variant, or variants with other types of lock, in the future. What function writer-side names would be suitable for such. (I don't know, but it seemed something that might be useful to consider.)
<snip>