2015-03-18 15:24, Ananyev, Konstantin: > > Hi Thomas, > > > -----Original Message----- > > From: Thomas Monjalon [mailto:thomas.monjalon at 6wind.com] > > Sent: Wednesday, March 18, 2015 1:14 PM > > To: Ananyev, Konstantin > > Cc: dev at dpdk.org > > Subject: Re: [dpdk-dev] [PATCH] EAL: move rte_common_vect.h into arch/x86 > > > > Hi Konstantin, > > > > 2015-03-18 10:58, Konstantin Ananyev: > > > lib/librte_eal/common/Makefile | 1 - > > > .../common/include/arch/x86/rte_common_vect.h | 128 > > > +++++++++++++++++++++ > > > lib/librte_eal/common/include/rte_common_vect.h | 128 > > > --------------------- > > > > I think rte_vect.h is a better name as common is not anymore relevant. > > I don't mind, but it means more changes - all files which include it, would > need to be changed.
I think file naming deserves it. > > Should we add an empty file in ppc_64 directory? > > I thought about that too, but it seems not necessary. > It is included by: > lib/librte_lpm/rte_lpm.h > lib/librte_eal/common/include/arch/x86/rte_memcpy.h > lib/librte_acl/rte_acl_osdep.h > > As I understand, neither LPM, neither ACL are supported on PPC right now. > Again, if we'll provide an empty one for PPC, it wouldn't help to compile > LPM/ACL on PPC anyway, > as both use SSE instrincts inside their code. Yes, it was an open question. It's probably better to create the PPC file when really needed.