> > > The mbuf offload flags do not match the DPDK namespace (they are > > > not prefixed by RTE_). Announce their rename in 21.11, and the > > > removal of the old names in 22.11. > > > > > > A draft coccinelle script is provided to anticipate what the > > > renaming will be. > > > > > > Signed-off-by: Olivier Matz <olivier.m...@6wind.com> > > > > Acked-by: Andrew Rybchenko <andrew.rybche...@oktetlabs.ru> > > > > [snip] > > > > > diff --git a/doc/guides/rel_notes/deprecation.rst > > > b/doc/guides/rel_notes/deprecation.rst > > > index 9584d6bfd7..04cb141de7 100644 > > > --- a/doc/guides/rel_notes/deprecation.rst > > > +++ b/doc/guides/rel_notes/deprecation.rst > > > +* mbuf: The mbuf offload flags ``PKT_*`` will be renamed as > > > ``RTE_MBUF_F_*``. > > > + A compatibility layer will be kept until DPDK 22.11, except for the > > > flags > > > + that are already deprecated (ex: ``PKT_RX_L4_CKSUM_BAD``), which will > > > + be removed. > > > > I think it is better to be explicit with defines to be removed: > > PKT_RX_L4_CKSUM_BAD, PKT_RX_IP_CKSUM_BAD, PKT_TX_QINQ_PKT, > > PKT_RX_EIP_CKSUM_BAD. > +1 > Acked-by: Ajit Khaparde <ajit.khapa...@broadcom.com>
Acked-by: Thomas Monjalon <tho...@monjalon.net> Applied with suggested changes.