14/04/2021 13:18, Akhil Goyal: > > > Splitting the complete testsuite into logical generic algo based sub > > > testsuite > > > Is a good idea. I appreciate that. > > > > > > But introducing PMD based test suite is not recommended. We have been > > > trying from past few releases to clean this up. And this patch is again > > introducing > > > the same. When I first saw this series, I saw only the algo based > > > splitting > > and > > > when it was run on the board, it was showing results in an organized way. > > > But this was not expected that, PMD based test suites are reintroduced by > > > Intel who helped in removing them in last few releases. > > > > > > This will make an unnecessary addition of duplicate code whenever a new > > PMD > > > is introduced. > > > > > > I recommend to use a single parent suite - cryptodev_testsuite and there > > > Can be multiple sub testsuites based on Algos etc. but not on the basis of > > PMD. > > > > > > Regards, > > > Akhil > > > > > > > Hey Akhil, I understand the sentiment of this, we were just trying to > > avoid necessary failures by executing testsuites which aren't supported > > by the PMD under test, and we're confident that all testsuites/tests are > > correctly verifying their capabilities requirements. If we add some code > > into the testsuite setup functions to test capabilities required for the > > testsuites vs those required by the PMD then we could do as you are > > suggesting. If we can make this change quickly would you consider this > > patchset for inclusion in RC2? > > I can take these patches upto RC2.
Please don't merge patches which go in the wrong direction.