13/04/2021 19:51, Akhil Goyal: > Splitting the complete testsuite into logical generic algo based sub testsuite > Is a good idea. I appreciate that. > > But introducing PMD based test suite is not recommended. We have been > trying from past few releases to clean this up. And this patch is again > introducing > the same. When I first saw this series, I saw only the algo based splitting > and > when it was run on the board, it was showing results in an organized way. > But this was not expected that, PMD based test suites are reintroduced by > Intel who helped in removing them in last few releases. > > This will make an unnecessary addition of duplicate code whenever a new PMD > is introduced. > > I recommend to use a single parent suite - cryptodev_testsuite and there > Can be multiple sub testsuites based on Algos etc. but not on the basis of > PMD.
+1 If a PMD has specifics, it should be expressed through the API, with capabilities or any other generic way.