24/03/2021 11:32, David Marchand: > Add a log message when registering log types and changing log levels. [...] > + RTE_LOG(DEBUG, EAL, "%s logtype level changed from %s to %s\n",
I would prefer "foo log level changed" instead of "foo logtype level changed". Opinions? > + rte_logs.dynamic_types[type].name == NULL ? > + "" : rte_logs.dynamic_types[type].name, In which case the logtype name is undefined? If it is unexexpected, should we have "unknown" instead of ""?