06/04/2021 15:32, Jerin Jacob:
> On Tue, Apr 6, 2021 at 1:10 AM Thomas Monjalon <tho...@monjalon.net> wrote:
> >
> > Use rte_set_application_usage_hook() in the test applications,
> > so the full help including EAL options can be printed in one go
> > with the EAL option -h or --help.
[...]
> > +       rte_set_application_usage_hook(print_usage);
> 
> All DPDK APIs, We are having rte_<subsystem><...><verb> kind of API
> name convention.
> I think, it is better to change to rte_application_usage_hook_set() to
> express the hierarchy.

The naming of this function is not fantastic.
Without thinking about a better name, we should ask if we want to go
through a deprecation of this function name?


Reply via email to