2015-07-22 13:35, Richardson, Bruce: > From: Zoltan Kiss [mailto:zoltan.kiss at linaro.org] > > On 22/07/15 10:59, Bruce Richardson wrote: > > > The vector PMD always works off a fixed 32 burst size. Any change to > > > that will lead to many changes in the code, so I don't believe a loop is > > necessary. > > > > Ok, then I suggest to make a comment around RTE_IXGBE_VPMD_RX_BURST that > > changing it needs a lot of other changes in the code elsewhere, e.g in > > this split_flags check. > > Btw. vPMD was a bit misleading abbreviation for me, it took me a while > > until I realized 'v' stands for 'vector', not 'virtualization' as in most > > cases nowadays. > > Good idea. I'll try to submit a patch to add a comment if I get the chance > - otherwise feel free to do so yourself.
Why not do it in this patch? Is it not enough related? > As for the naming, yes, I suppose it can be confusing. :-) We possibly need > to start calling these pieces of code SSE or AVX rather than just vector, > since for some we may end up with multiple vector versions. +1 for SSE/AVX naming