> -----Original Message----- > From: Thomas Monjalon <tho...@monjalon.net> > Sent: Tuesday, October 27, 2020 16:52 > To: Wang, Haiyue <haiyue.w...@intel.com> > Cc: dev@dpdk.org; Yigit, Ferruh <ferruh.yi...@intel.com>; > david.march...@redhat.com; Richardson, Bruce > <bruce.richard...@intel.com>; olivier.m...@6wind.com; > andrew.rybche...@oktetlabs.ru; > akhil.go...@nxp.com; Doherty, Declan <declan.dohe...@intel.com>; Ankur > Dwivedi <adwiv...@marvell.com>; > Anoob Joseph <ano...@marvell.com>; Guo, Jia <jia....@intel.com>; Jerin Jacob > <jer...@marvell.com>; > Nithin Dabilpuram <ndabilpu...@marvell.com>; Kiran Kumar K > <kirankum...@marvell.com>; Nicolau, Radu > <radu.nico...@intel.com>; Ray Kinsella <m...@ashroe.eu>; Neil Horman > <nhor...@tuxdriver.com> > Subject: Re: [PATCH v2 05/15] security: switch metadata to dynamic mbuf field > > 27/10/2020 03:01, Wang, Haiyue: > > From: Thomas Monjalon <tho...@monjalon.net> > > For ixgbe PMD, > > > > Acked-by: Haiyue Wang <haiyue.w...@intel.com> > > > > But I feel that 'rte_security_dynfield' name is too generic, can it be > > more specific about what the field is used for ? > > > > Like below ;-) > > > > #define RTE_SECURITY_DEV_METADATA(m) \ > > RTE_MBUF_DYNFIELD((m), \ > > rte_security_dev_metadata_offset, \ > > RTE_SECURITY_DEV_METADATA_TYPE *) > > Yes rte_security_dynfield is too much generic, > as well as RTE_SECURITY_DEV_METADATA. > It seems there are different data stored in this field. > We should have different fields for different data. > But such cleanup is another step for someone else.
Understood, thanks, then 'DEV_METADATA' is also generic. > >