On 9/18/2020 3:17 PM, Ophir Munk wrote:
From: Ophir Munk <ophi...@mellanox.com>
This is a cleanup commit. It assembles all tunnel outer updates into one
function call to avoid code duplications.
It defines RTE_VXLAN_GPE_DEFAULT_PORT (4790) in accordance with all
other tunnel protocol definitions.
Signed-off-by: Ophir Munk <ophi...@mellanox.com>
---
app/test-pmd/csumonly.c | 72 +++++++++++++---------------------------------
lib/librte_net/rte_vxlan.h | 1 +
2 files changed, 21 insertions(+), 52 deletions(-)
diff --git a/app/test-pmd/csumonly.c b/app/test-pmd/csumonly.c
index a9f33c6..7f9bfa6 100644
--- a/app/test-pmd/csumonly.c
+++ b/app/test-pmd/csumonly.c
@@ -63,7 +63,7 @@
#define _htons(x) (x)
#endif
-uint16_t vxlan_gpe_udp_port = 4790;
+uint16_t vxlan_gpe_udp_port = RTE_VXLAN_GPE_DEFAULT_PORT;
uint16_t geneve_udp_port = RTE_GENEVE_DEFAULT_PORT;
'RTE_VXLAN_DEFAULT_PORT' seems defined but '4789' still used as hardcoded in
this file, since you are touching these, can you please update that usage too?