On Fri, Sep 11, 2020 at 01:32:15PM +0200, David Marchand wrote: > On Fri, Sep 11, 2020 at 9:43 AM David Marchand > <david.march...@redhat.com> wrote: > > > > On Fri, Sep 11, 2020 at 8:15 AM SteveX Yang <stevex.y...@intel.com> wrote: > > > > > > The depended pmd bond is missing for test-pmd. Add the pmd_bond to deps, > > > and replace the relative MACRO name with new RTE_LIBRTE_BOND_PMD. > > > > meson changed the name of the driver define (when compared to make). > > It is likely we have other similar issues. > I excluded the doc, since we have pending patches. > > *Disclaimer* My scripting might be buggy. > > $ git grep -h DIRS-..CONFIG_RTE_ v20.08 -- drivers/*/Makefile |sed -e > 's#DIRS-$(CONFIG_\(.*\)).*$#\1#' |sort > make.tokens > $ for meson in drivers/*/meson.build; do dir=$(dirname $meson); > format=$(git grep 'config_flag_fmt =' $meson |cut -d \' -f 2); for drv > in $dir/*; do drvname=$(basename $drv |tr '[a-z]' '[A-Z]'); echo > $format |sed -e "s/@0@/$drvname/"; done; done |sort > meson.tokens > > $ for token in $(diff -u make.tokens meson.tokens |sed -n > 's/^-\(RTE_LIBRTE.*\)/\1/p'); do output=$(git grep -l "$token\>" -- > :^doc/) || continue; echo $token $output; done > RTE_LIBRTE_PMD_AESNI_GCM app/test/test_cryptodev.c > RTE_LIBRTE_PMD_AESNI_MB app/test/test_cryptodev.c > app/test/test_cryptodev_hash_test_vectors.h > RTE_LIBRTE_PMD_BOND app/test-pmd/cmdline.c app/test-pmd/parameters.c > RTE_LIBRTE_PMD_CAAM_JR app/test/test_cryptodev.c > RTE_LIBRTE_PMD_CCP app/test/test_cryptodev.c > RTE_LIBRTE_PMD_CRYPTO_SCHEDULER app/test-crypto-perf/main.c > app/test/meson.build app/test/test_cryptodev.c > examples/l2fwd-crypto/main.c > RTE_LIBRTE_PMD_DPAA2_EVENTDEV drivers/bus/fslmc/portal/dpaa2_hw_dpio.c > RTE_LIBRTE_PMD_DPAA2_SEC app/test/test_cryptodev.c > RTE_LIBRTE_PMD_DPAA_SEC app/test/test_cryptodev.c > RTE_LIBRTE_PMD_KASUMI app/test/test_cryptodev.c > RTE_LIBRTE_PMD_MVSAM_CRYPTO app/test/test_cryptodev.c > RTE_LIBRTE_PMD_NITROX app/test/test_cryptodev.c > RTE_LIBRTE_PMD_NULL app/test/test_cryptodev.c > RTE_LIBRTE_PMD_OCTEONTX2_CRYPTO app/test/test_cryptodev.c > app/test/test_cryptodev_asym.c > RTE_LIBRTE_PMD_OCTEONTX_CRYPTO app/test/test_cryptodev.c > app/test/test_cryptodev_asym.c > RTE_LIBRTE_PMD_OPENSSL app/test/test_cryptodev.c > app/test/test_cryptodev_asym.c > RTE_LIBRTE_PMD_RING app/test/test_eal_flags.c > RTE_LIBRTE_PMD_SNOW3G app/test/test_cryptodev.c > RTE_LIBRTE_PMD_VIRTIO_CRYPTO app/test/test_cryptodev.c > RTE_LIBRTE_PMD_ZUC app/test/test_cryptodev.c > RTE_LIBRTE_SFC_EFX_PMD config/arm/meson.build > > Can this be looked at? > Thanks. > Sure. What do you think we should do for these, do we just document the change in the documentation, or should we keep strict compatibility by adding legacy defines?
I don't particularly like keeping the old defines around, since they are inconsistent in naming, but since we didn't announce a deprecation of the old values perhaps we should add them in. Thoughts? /Bruce