Hi Pablo, > +#if IMB_VERSION_NUM >= IMB_VERSION(0, 53, 3) > + processed_ops = process_zuc_hash_op_mb(qp, ops, sessions, > + num_ops); > +#else > processed_ops = process_zuc_hash_op(qp, ops, sessions, > num_ops); > +#endif > break;
Instead of having a separate name for process_zuc_hash_op in case of newer IMB version, Is it not better to have same name of the function but having different definitions for different IMB version. This way you can reduce the #ifs in the code. Regards, Akhil