> @@ -152,6 +159,7 @@ struct rte_pci_device { > uint16_t max_vfs; /**< sriov enable if not zero */ > int numa_node; /**< NUMA node connection */ > struct rte_devargs *devargs; /**< Device user arguments */ > + enum rte_pt_driver pt_driver; /**< Driver of passthrough */ [...] > +static int > +pci_get_kernel_driver_by_path(const char *filename, char *dri_name)
I think "kernel driver" is a good name. Why not using this name in the pci_device struct to be more consistent? Thanks