[PATCH v14 1/3] ethdev: decouple flow types and RSS offload types. [PATCH v14 2/3] ethdev: add several bits for extending rss offload types. [PATCH v14 3/3] app/testpmd: add cmdline support for extending rss types.
v14: * Adjust the location of the inline function. v13: * Define an inline function. v12: * Use a macro to replace a function. v11: * Update code logic in rte_eth_dev_configure() and rte_eth_dev_rss_hash_update(). v10: * Modify duplicate logic in rte_eth_dev_configure() and rte_eth_dev_rss_hash_update(). v9: * Fix code style. * Delete duplicate logic in rte_eth_dev_configure(). v8: * Add to check the simultaneous use of SRC/DST_ONLY of the same level in rte_eth_dev_rss_hash_update() and rte_eth_dev_configure(). * Update code comments. v7: * Supplement related configuration for new flag in app/test-pmd/cmdline.c. v6: * Add the new flag in app/test-pmd/cmdline.c. v5: * Update code comments. v4: * Divide one patch into two patches. * Delete ETH_RSS_L2_SRC/DST_ONLY. v3: * Update code comments and code style. v2: * Update code comments. Simei Su (3): ethdev: decouple flow types and RSS offload types ethdev: extend RSS offload types app/testpmd: add RSS offload types extending support app/test-pmd/cmdline.c | 14 ++++++- app/test-pmd/config.c | 4 ++ lib/librte_ethdev/rte_ethdev.c | 5 +++ lib/librte_ethdev/rte_ethdev.h | 87 +++++++++++++++++++++++++++++------------- 4 files changed, 81 insertions(+), 29 deletions(-) -- 1.8.3.1