30/07/2019 15:39, Thomas Monjalon:
> The names of the rawdev drivers and the resultant libraries they built
> were pretty inconsistent. In terms of directory names, some had "rawdev"
> in the name, e.g. skeleton_rawdev, ifpga_rawdev, while others didn't.
> Also, for the built .so/.a libraries, the names were not always
> consistent between make and meson, as, while meson enforced a consistent
> naming scheme, make did not, leading to differences - especially for
> those drivers with "rawdev" in the directory name.
> 
> This patchset attempts to make things more standardized by removing
> "rawdev" from all directory names - the drivers are in the "drivers/raw"
> directory after all - and then standardizing the library names to
> "librte_rawdev_<name>" for both make and meson.
> 
> Bruce Richardson (2):
>   drivers/raw: remove rawdev from directory names
>   drivers/raw: standardize naming
> 
> v2 (Thomas):
> - update doc and MAINTAINERS file
> - rebase for ntb and octeontx2

Applied



Reply via email to