Hi Jerin, Please see inline.
Thanks, Anoob > -----Original Message----- > From: Jerin Jacob Kollanukkaran > Sent: Monday, June 10, 2019 3:54 PM > To: Anoob Joseph <ano...@marvell.com>; Nikhil Rao > <nikhil....@intel.com>; Erik Gabriel Carrillo <erik.g.carri...@intel.com>; > Abhinandan Gujjar <abhinandan.guj...@intel.com>; Bruce Richardson > <bruce.richard...@intel.com>; Pablo de Lara > <pablo.de.lara.gua...@intel.com> > Cc: Anoob Joseph <ano...@marvell.com>; Narayana Prasad Raju Athreya > <pathr...@marvell.com>; dev@dpdk.org; Lukas Bartosik > <lbarto...@marvell.com>; Pavan Nikhilesh Bhagavatula > <pbhagavat...@marvell.com>; Hemant Agrawal > <hemant.agra...@nxp.com>; Nipun Gupta <nipun.gu...@nxp.com>; Harry > van Haaren <harry.van.haa...@intel.com>; Mattias Rönnblom > <mattias.ronnb...@ericsson.com>; Liang Ma <liang.j...@intel.com> > Subject: RE: [PATCH 19/39] eventdev: add common initialize routine for > eventmode devs > > > -----Original Message----- > > From: Anoob Joseph <ano...@marvell.com> > > Sent: Monday, June 3, 2019 11:02 PM > > To: Jerin Jacob Kollanukkaran <jer...@marvell.com>; Nikhil Rao > > <nikhil....@intel.com>; Erik Gabriel Carrillo > > <erik.g.carri...@intel.com>; Abhinandan Gujjar > > <abhinandan.guj...@intel.com>; Bruce Richardson > > <bruce.richard...@intel.com>; Pablo de Lara > > <pablo.de.lara.gua...@intel.com> > > Cc: Anoob Joseph <ano...@marvell.com>; Narayana Prasad Raju Athreya > > <pathr...@marvell.com>; dev@dpdk.org; Lukas Bartosik > > <lbarto...@marvell.com>; Pavan Nikhilesh Bhagavatula > > <pbhagavat...@marvell.com>; Hemant Agrawal > <hemant.agra...@nxp.com>; > > Nipun Gupta <nipun.gu...@nxp.com>; Harry van Haaren > > <harry.van.haa...@intel.com>; Mattias Rönnblom > > <mattias.ronnb...@ericsson.com>; Liang Ma <liang.j...@intel.com> > > Subject: [PATCH 19/39] eventdev: add common initialize routine for > > eventmode devs > > > > Adding framework for common initialization routine for event mode. > > Event mode would involve initialization of multiple devices, like > > eventdev, ethdev etc and this routine would be the placeholder for all > > initialization to come in. > > > > Signed-off-by: Anoob Joseph <ano...@marvell.com> > > Signed-off-by: Lukasz Bartosik <lbarto...@marvell.com> > > --- > > > > +/* Helper functions for initialization, & launching workers */ > > + > > +/** > > + * Initialize event mode devices > > + * > > + * Application could call this function to get the event device, eth > > +device > > + * and eth rx adapter initialized according to the conf populated > > +using the > > + * command line args. > > + * > > + * Application is expected to initialize the eth device and then the > > +eventmode > > + * helper subsystem will stop & start eth device according to it's > > requirement. > > + * So call to this function should be done after the eth device is > > +successfully > > + * initialized. > > + * > > + * @param mode_conf > > + * Configuration of the mode in which app is doing packet handling > > + * @return > > + * - 0 on success. > > + * - (<0) on failure. > > + */ > > +int32_t __rte_experimental > > +rte_eventmode_helper_initialize_devs( > > + struct rte_eventmode_helper_conf *mode_conf); > > + > > # Prefer to change to rte_event_helper_init() and introduce the counter part [Anoob] This routine is doing init of devs (not the helper library). So are you okay with renaming it to rte_event_helper_devs_init() and rte_event_helper_devs_uninit(), and retain the functionality as before? > for the same(rte_event_helper_uninit() or rte_event_helper_fini()) # > introduce params structure taking another paraments input instead of new > APIs. > # let library return rte_event_helper_conf* object for further operations. [Anoob] Parse args will parse the command line arguments and return the conf. Based on the conf we setup the required devices (eventdev, Rx adapter & Tx adapter, can be expanded to handle ethdev also). > > > > #ifdef __cplusplus > > } > > #endif > > -- > > 2.7.4