Hi Stephen, On Mon, Apr 22, 2019 at 09:00:45AM -0700, Stephen Hemminger wrote: > On Wed, 10 Apr 2019 10:32:05 +0200 > Olivier Matz <olivier.m...@6wind.com> wrote: > > > Add 'rte_' prefix to structures: > > - rename struct arp_hdr as struct rte_arp_hdr. > > - rename struct arp_ipv4 as struct rte_arp_ipv4. > > > > Also rename arp_hrd, arp_pro, arp_hln, arp_pln and arp_op fields > > to avoid conflict with the #defines in gnu libc. > > > > Signed-off-by: Olivier Matz <olivier.m...@6wind.com> > > Agree that adding prefix is best way to handle rte_arp.h. > > Could you fix up all the checkpatch whitespace warnings on > this and resubmit it as a PATCH (not RFC)?
I don't think fixing all whitespace warnings in the patchset is a good thing. It's not new code, and only fixing the parts I'm modifying may result in style inconsistency. I'll have a look on a case by case basis. Thanks Olivier